http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-mac-osx



How to create a bootable USB stick on OS X

  1. Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight).

  2. 3

    Convert the .iso file to .img using the convert option of hdiutil e.g., 

    hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso

    Note: OS X tends to put the .dmg ending on the output file automatically.

  3. 4

    Run 

    diskutil list
    to get the current list of devices.

  4. 5

    Insert your flash media.

  5. 6

    Run 

    diskutil list
    again and determine the device node assigned to your flash media (e.g. /dev/disk2).

  6. 7

    Run 

    diskutil unmountDisk /dev/diskN
    (replace N with the disk number from the last command; in the previous example, N would be 2).

  7. 8

    Execute 

    sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m
    (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).

    • Using /dev/rdisk instead of /dev/disk may be faster
    • If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M
    • If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive
  8. 9

    Run 

    diskutil eject /dev/diskN
    and remove your flash media when the command completes.

  9. 10

    Restart your Mac and press alt/option key while the Mac is restarting to choose the USB stick.


+ Recent posts