Post subject: Re: WOL over net
Posted: Tue Nov 17, 2009 2:03 am 


Forum Veteran



Joined: Fri Aug 17, 2007 8:42 am
Posts: 730 
Karma: 24
It's way easier:

example LAN segment is: 192.168.1.0/24

create static arp entry to resolve IP -> broadcast
Code:
/ip arp add address=192.168.1.254 comment="" disabled=no interface=LAN mac-address=FF:FF:FF:FF:FF:FF


create a NAT rule to forward packet on specific to this IP (effectively sending it to broadcast MAC)
Code:
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.1.254 to-ports=7 protocol=udp dst-port=7000


tell your WoL client to send a packet to <your IP> port 7000. packet comes in, get's forwarded to broadcast MAC out LAN interface to port 7.

Works great.

_________________
Doug

출처 : http://forum.mikrotik.com/viewtopic.php?f=9&t=36718
참고 : http://wiki.mikrotik.com/wiki/Wake_on_lan


http://wiki.mikrotik.com/wiki/


Welcome to the MikroTik Wiki! 

This is a place where users of MikroTik solutions share information, examples, howtos and ideas with each other. 

This resource consists of both User Maintained How-To articles, and also MikroTik maintained documentation pages. 

Choose your category below:

Ros.pngMikrotik RouterOS 
Documentation
News.pngMikroTik News 
News and related information
Routerboard.pngRouterBOARD hardware 
RouterBOARD hardware Pages
Mum.pngMUM Events 
Mikrotik User Meetings around the world
Userman.pngMikroTik User Manager 
MikroTik User Manager
Dude.pngThe Dude 
The Dude
User.pngRouterOS User Topics 
Articles and Examples written by users
RB250GS.pngSwOS 
SwOS for MikroTik Switch products

http://wiki.mikrotik.com/wiki/Forwarding_a_port_to_an_internal_IP

위 링크에 terminal에서 하는 방법이 설명되어져 있습니다.


Forwarding a port to an internal IP

This example will show you how to forward port (tcp 5900) to an internal IP using destination NAT. 69.69.69.69 is the example wan IP, 192.168.1.101 is the desired internal destination.

/ip firewall nat add chain=dstnat dst-address=69.69.69.69 protocol=tcp dst-port=5900 \
    action=dst-nat to-addresses=192.168.1.101 to-ports=5900



위 예제에서 69.69.69.69 가 외부 공인(wan)IP이고 192.168.1.101이 내부 사설IP임을 알 수 있습니다.

응용해서 적용하면 됩니다.


* gui로 하고 싶다면 아래 유튜브 동영상을 참고 하세요.







+ Recent posts